• A
  • A
  • A
  • АБВ
  • АБВ
  • АБВ
  • А
  • А
  • А
  • А
  • А
Обычная версия сайта

VS Code для подключения к суперкомпьютеру

Visual Studio Code - текстовый редактор, обладающий функциями IDE, с возможностью настройки и расширения при помощи плагинов. 


*Не является рекомендуемым способом подключения к суперкомпьютеру. Рекомендуемый способ: подключение через SSH (PuTTY + WinSCP).

Совместимость. После перевода суперкомпьютера на Rocky Linux 9 поддерживаются актуальные версии VS Code и расширения Remote‑SSH. Устанавливать старые версии VS Code или отключать автооновление не нужно. Если вы ранее закрепили старую версию VS Code, обновите её.

Обязательно завершайте работу c кластером через VS Code командой:
pkill -u $USER -f vscode-server
Остающиеся после VS Code процессы создают конфликты при следующем запуске. Команда пишется в терминале, который можно открыть, нажав на соответствующую кнопку в правой верхней части редактора.


Подготовка к соединению

Для подключения к суперкомпьютеру через VS Code необходимо установить плагин Remote-SSH (издатель Microsoft). Перейдите на вкладку View -> Extensions.

Рис. 1. Переход на вкладку с расширениями

В поисковой строке вводим Remote-SSH и устанавливаем расширение.

Рис. 2. Установка расширения

Нажимаем на появившуюся иконку удалённого подключения, появляется вкладка SSH. Выбираем опцию New remote.

new-remote

Рис. 3. Создание нового удалённого соединения

Далее необходимо ввести данные для подключения: ssh <логин_от_кластера>@cluster.hpc.hse.ru

add-cluster

Рис. 4. Ввод данных для подключения

Далее будет предложено сохранить конфигурацию в файл – выберите конфигурацию по умолчанию.

choose-config-file

Рис. 5. Сохранение конфигурации подключения

Проверьте содержимое файла конфигурации.

Рис. 6. Проверка конфигурации подключения

Подготовка ключа доступа

Для подключения к кластеру через VS Code необходим ключ в формате .pem. Его можно сгенерировать в личном кабинете TaskMaster.

Инструкция по конвертации ключа .ppk в формат .pem

Для конвертации .ppk ключа, можно воспользоваться программой PuTTYgen, скачав её с официального сайта. Выберите свежую официальную версию программы. Запустите программу puttygen.exe. Далее в File -> Load private key загрузите свой текущий ключ доступа в формате .ppk.

load-pk

Рис. 7. Загрузка ключа в формате .ppk

Программа попросит ввести пароль от этого ключа.

password-key

Рис. 7. Ввод пароля для ключа

Далее в разделе Conversions выбираем Export OpenSSH key и сохраняем файл в директорию

%USERPROFILE%\.ssh

*Файл с ключом можно сохранить и в другой папке. Главное – чтобы она лежала в домашней директории пользователя.

password-key

Рис. 8. Экспорт ключа в формате для OpenSSH

Завершение настройки

Вернитесь в VS Code. Укажите в файле config порт и путь до ключа авторизации. Файл должен выглядеть следующим образом. В Linux/macOS IdentityFile ~/.ssh/auth_key.pem (права на файл: chmod 600 ~/.ssh/auth_key.pem).

Host super
HostName cluster.hpc.hse.ru
User <логин_от_кластера>
Port 2222
IdentityFile "C:\Users\<имя_пользователя_Windows>\.ssh\auth_key.pem"


Рис. 9. Итоговый вид конфигурационного файла

Рекомендуемые настройки VS Code (File → Preferences → Settings → Open Settings (JSON)):

"remote.SSH.remotePlatform": { "super": "linux" },
"files.watcherExclude": {
"**/.git/objects/**": true,
"**/node_modules/**": true,
"**/*.sif": true,
"**/data/**": true
}

Для подключения к кластеру нажмите на иконку удалённого подключения в нижней части редактора.

another-connection

Рис. 10. Иконка удалённого подключения

Выберите опцию для подключения к хосту.

another-host-connect

Рис. 11. Выбор варианта удалённого подключения

В открывшемся окне выберите cluster.hpc.hse.ru.

cluster-connection

Рис. 12. Выбор хоста для подключения

Система попросит ввести пароль от ключа – вводим и получаем доступ к суперкомпьютеру.

password-to-in

Рис. 13. Ввод пароля от ключа доступа

Для проверки доступа: внизу редактора должно появится название хоста, к которому Вы подключены.

name-host

Рис. 14. Проверка подключения

Настроим отображение Ваших файлов. Для этого перейдите в меню Explorer и выберите Open Folder. Не открывайте весь домашний каталог, если в нём много данных.

open-folder

Рис. 15. Кнопка для открытия окна с выбором директории

Далее выберите нужную Вам папку или сразу нажмите OK, чтобы был доступен весь Ваш каталог.

Рис. 16. Выбор рабочей директории

В левой колонке во вкладке Explorer появится Ваша выбранная папка. Для работы в терминале перейдите в View -> Terminal. Для быстрого обмена файлами между локальным устройством и удаленным хостом просто перетащите мышкой необходимый файл.

Если подключение не работает (сервер не стартует, «Could not establish connection», ошибки библиотек): удалите старый серверный кэш и подключитесь заново:

pkill -u $USER -f vscode-server
rm -rf ~/.vscode-server

Обязательно завершайте работу c кластером через VS Code командой:
pkill -u $USER -f vscode-server
Остающиеся после VS Code процессы создают конфликты при следующем запуске. Команда пишется в терминале, который можно открыть, нажав на соответствующую кнопку в правой верхней части редактора.



 

Нашли опечатку?
Выделите её, нажмите Ctrl+Enter и отправьте нам уведомление. Спасибо за участие!
Сервис предназначен только для отправки сообщений об орфографических и пунктуационных ошибках.